Results 1 to 9 of 9

Thread: anyone had luck with simplex

  1. #1
    Join Date
    Jun 2010
    Location
    Spring Creek Pa
    Posts
    143

    anyone had luck with simplex

    We have a newer fire panel about a year old. we have had simplex in here about 6 times to trouble shoot a open circuit trouble on our panel. every time the come in and "fix something" but it doesn't last.

    right now our fault open on SIGI16 keeps coming on an clearing with no one touching anthing today I re tightened all the screws on the control boards in question. although there were no error lights???

    Still seems to have the issue??

    any ideas seem to me our management here doesn't want to do anything to fix issue??

  2. #2
    Join Date
    Apr 2016
    Location
    Raleigh, NC USA
    Posts
    342
    My experience with Simplex is that they are very expensive and are only as good as the technician that they send.

    We had two techs come out for our yearly fire system check. They replaced a bad pull station. It was incorrectly installed and a skinned wire was shorting out. Long story short they sent out a service tech the next day to fix it. Then sent a huge bill for the service call to fix the pull station that their techs screwed up.

    If you are having an ongoing issue, that started before the one year warranty ended I would be pushing them to fix it under the warranty.

  3. #3
    Join Date
    Jun 2010
    Location
    Spring Creek Pa
    Posts
    143
    I think they should fix it under warranty as well. but I am just the maintenance guy. was wondering if others had same problems.
    and from your post there are others.

  4. #4
    Join Date
    Mar 2003
    Location
    New England
    Posts
    12,981
    I've never heard a single good thing about Simplex over the years.

  5. #5
    Join Date
    Dec 2007
    Location
    NE Nebraska
    Posts
    31,312
    I can't say anything good or bad about Simplex, but if it is saying there is an open circuit - the problem is probably out in the premises wiring and not a problem with the panel. Something is intermittently opening somewhere most likely a poor termination on a device or a defective end of line resistor.

  6. #6
    Join Date
    Sep 2015
    Location
    Brooklyn
    Posts
    9
    If the open circuit is a NAC/zone with a EOL resistor then put the resistor on the terminal by the FACP for a couple of days or however long it takes for the trouble to show and u will know if it's the panel or the circuit.

  7. #7
    Join Date
    Jun 2010
    Location
    Spring Creek Pa
    Posts
    143
    thanks for the infomation guys. i quess my concern is we never had this issue untill they installed the new panel. then is starts to show up.
    they have been at our plant atleast 5 times and they cant seem to ever fix it. thats what makes me think its a panel issue because if it was a field issue we would have had that problem before i would think???

  8. #8
    Join Date
    Dec 2007
    Location
    NE Nebraska
    Posts
    31,312
    Quote Originally Posted by Barndog View Post
    thanks for the infomation guys. i quess my concern is we never had this issue untill they installed the new panel. then is starts to show up.
    they have been at our plant atleast 5 times and they cant seem to ever fix it. thats what makes me think its a panel issue because if it was a field issue we would have had that problem before i would think???

    Swap leads from a different zone, if there is a problem in zone wiring the fault should move with it.

  9. #9
    Join Date
    Nov 2008
    Location
    Twin Cities, MN
    Posts
    81
    Quote Originally Posted by Barndog View Post
    thanks for the infomation guys. i quess my concern is we never had this issue untill they installed the new panel. then is starts to show up.
    they have been at our plant atleast 5 times and they cant seem to ever fix it. thats what makes me think its a panel issue because if it was a field issue we would have had that problem before i would think???
    Why don't you have another fire alarm company out to work on it then if you keep having issues with Simplex? Is it out of warranty?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •