Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: LED Tape under cabinet install

  1. #11
    Join Date
    May 2005
    Location
    Richmond, Virginia
    Posts
    23,347
    Quote Originally Posted by sw_ross View Post
    Anyone ever have problems with the 3M adhesive on the tape light?
    I carry a bottle of contact cement for questionable adhesion, the kind you apply to both sides and allow to dry before assembly.
    Code references based on 2005 NEC
    Larry B. Fine
    Master Electrician
    Electrical Contractor
    Richmond, VA

  2. #12
    Join Date
    Oct 2015
    Location
    US
    Posts
    651
    I don't trust the tape I usually install in some sort of channel like this. If you can. See all those little burn marks on the bottom of the cabinets those were actually from the old 12v halogen bulbs. I replaced them with these used the same wiring just Changed fixtures and driver

    Sent from my SM-G950U using Tapatalk

  3. #13
    Join Date
    Oct 2015
    Location
    US
    Posts
    651
    Sorry so I screw these to bottom of cabinets and the tape sticks pretty good to the aluminum I usually wipe them down with some alcohol swabs before and I never had a problem

    Sent from my SM-G950U using Tapatalk

  4. #14
    Quote Originally Posted by nickelec View Post
    I don't trust the tape I usually install in some sort of channel like this. If you can. See all those little burn marks on the bottom of the cabinets those were actually from the old 12v halogen bulbs. I replaced them with these used the same wiring just Changed fixtures and driver

    Sent from my SM-G950U using Tapatalk
    This is what I use as well, just yesterday in fact.

    Armacost Lighting has some connections that are very solid.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •