Announcement

Collapse
No announcement yet.

Help! Everybody stumped!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help! Everybody stumped!

    We have an electrical furnace (Nortron D series) installed in 2019 that keeps tripping the furnace breaker. (Federal Pioneer breaker box). Breaker is a 150 amp and costs $400 a piece! Electricians meter showing it pulls max of 103 amps. I've been thru three 150 amp breakers. They work for a while then they start tripping more and more thus having to be replaced. Power Corp. Has checked current from pole to house. No problems. Electricians have checked the furnace to the panel, no problems. Yesterday Electrician switched breaker to another location (just under main breaker) on panel. Still popped. Info: main breaker is 200amps. Breaker for furnace is 150amps. Furnace has three breakers for the elements and never have these breakers popped. By the way, we replaced the furnace (original installed in 2011) thinking it was faulty. But the same problem is occurring. Can anyone help fix this as we can't leave our house and chance frozen water lines! If you have suggestions! We have pictures but this forum wouldn't let me upload. Thanks in advance! Bryan.
    Last edited by Little Bill; 10-10-19, 12:22 PM.

    #2
    I would suggest trying another electrician and/or contacting the furnace mfg.
    With that said, we can't really help any further so...

    I am closing this thread, in accordance with the Forum Rules.

    This site is designed for:[list][*]Contractors[*]Electricians[*]Engineers[*]Inspectors[*]Instructors[*]Other electrically related individuals[/list]

    * This NEC Forum is for those in the electrical and related industries. Questions of a "How-To" nature by persons not involved in the electrical industry will be removed without notice.
    If you feel this action to be in error, feel free to contact me via PM to explain.

    A reminder to all members, if you see a questionable post, feel free to report it by clicking the “Flag” icon at the bottom right corner of the post.
    [COLOR=navy]If you aim at nothing, you will hit it every time![/COLOR]

    Comment

    Working...
    X