Announcement

Collapse
No announcement yet.

VFD noise

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VFD noise

    Hello,

    I am running a 75 hp 480v drive (Durapulse) for a water pump.

    This morning I energized it and it made a loud rattle like a contactor was opening and closing rapidly . I switched out the board from another drive and the same thing happens. If I disconnect the cooling fans the rattle stops. There is a relay at the top right of the main board that also switches on and off.

    Any ideas? Thanks

    #2
    Sounds like there is a loose connection some where in the control circuit that controls the fans.
    The rattle you hear is probably that relay picking up and dropping out due to the vibration when
    the fans are running. When you switch off the fans the power to that relay is disconnected and
    the rattling (and fans) stops.
    Ifyoucan'texplain itsimply youdon'tunderrstanditwellenough- Albert Einstein

    Comment


      #3
      How old is the drive? Cooling fans are usually the first thing to go bad, but their failure then precipitates other failures, so the only thing you see is the collateral damage that happens AFTER the fan fails. You may have dodged a bullet here.

      The other possibility would be what's called the "pre-charge circuit" in the drive. All drives have some form of this because it is necessary to prevent the capacitor charging current that takes place whenever the drive is first energized from damaging the caps themselves or other components in the drive. The most common form of pre-charge circuit is to have a current limiting resistor on the DC side of the rectifier, then a relay / contactor that shorts out that resistor a second or so after first energizing the drive. That resistor / contactor is good for about 1,000 operations, which if you powered down the drive once per week would be good for 20 years. But if you power it down once per day, it's less than 3 years. I mention this because you said it took place when you first powered it up, which is typical of a failing pre-charge circuit, that "rattle" is the pre-charge contactor chattering.

      The thing that DOESN'T fit however is the issue of it going away when you disconnect the fans. But it MIGHT be that Delta (the actual mfr of those AutomationDestruct drives) is powering the cooling fans from the pre-charge circuit board to save money, so a bad fan might be draining power from that board, giving the pre-charge contactor a low voltage to its coil, causing it to chatter. If that's the case, you may have already smoked the pre-charge resistor, in which case your drive is doomed to failure if it is not repaired before the next time you even apply power. I would send it in for repair immediately, this may be something you can't fix in the field because of the cascading nature of these issues.
      __________________________________________________ ____________________________
      Many people are shocked when they discover I am not a good electrician...

      I'm in California, ergo I am still stuck on the 2014 NEC... We'll get around to the 2017 code in around 2021.

      Comment

      Working...
      X